Rebellion

LURP1

Last Activity
Sat, Mar 4, 2017 8:01 AM
Posts Made
This user has made 10 posts.

Recent Posts

Posted 2 years ago

 try lowering you settings do not use ultra or high and see if this helps.

LURP1
-1

Posted 2 years ago

 lower your settings do not use ultra or high and see if it helps.

Posted 2 years ago

 do not use ultra or high settings and see if it helps.

Posted 2 years ago

 you may have to lower your settings to a lower setting don't use ultra or high .

Posted 2 years ago

 you using a mouse or game controler?  ah a 980 I have noticed that players using the 970 all seem to have issues with the game perhaps also with the 980,  I use 1050ti MSI twin frozer card and have had no game issues I think these cards need to be upgraded to solve many problems.

Posted 2 years ago

 you need to upgrade your 970, I use 1050ti MSI twin frozer card and have no problems at all the game runs at a steady 60fps . I have noticed in this forum that people using the 970 all have problems.

LURP1
-1

Posted 2 years ago

 sounds like your graphic's cards need to be upgraded,  I use 1050ti MSI twin frozer card and have had no issues in game runs smooth at a stedy 60fps.

Posted 2 years ago

 sounds like graphic card issue, I use 1050ti card and have had no issues at all in game . my card is MSI  twin frozer.  Can you clock your system?

Posted 2 years ago

 I have had no problems with lag or stalls in this game what G card are you using?

Posted 2 years ago

 I have never had this problem but I am using a PC I think it is a issue with Xbox.