Rebellion

Sniper Elite 4

General » PC

3

Posts

Co-op broken, Horrible lag with good internet.

Posted 2 years ago

 So we are having a problem with the co-op mode with my friend.

When hosting or joining a public co-op the connection seems to be horrible, it shows at first that we have great connection (4 green bars) on the lobby, but when you tap ready or start it goes red and the game if it proceeds to start is lagging like legless retard running, doesn't matter either one of us host problem still is there.

We both have forwarded the ports that the game needs, both have good connection of 50/10mb/s from the same internet provider and we live about 200meters apart from eachother. both have checked the game files in steam.

On the multiplayer side for example game of TDM there's no lag and it shows 4 green bars for ping. 

Please fix this. its expensive to buy shit that you have to make yourself to make it work.....

Posted 2 years ago

 wont even work with hamachi or tungle, tried about everything...

Posted 2 years ago

 They are aware of this issue should be a fix in the  ugly patch they are bringing out. 

Please sign in to post.

Sign in to search.

Please sign in to post.

Recent Activity
1

Support (PC)

Beldeth posted 2 years ago

8

Game crashes 1/18/2019

jweg posted 5 months ago

1

Changing characters

PGProf posted 7 months ago

1

lütfen yardım edin

SAPHIRE posted 8 months ago

1

Admins

Goatface posted 1 year ago

1

no sound

Nathan5660 posted 1 year ago

General » PC