Rebellion

Sniper Elite 4

8

Posts

Scope not working

Posted 2 years ago

Am I the only one with this problem? I cannot snipe since I can only get the over the shoulder crosshairs. I tried restarting and a different account. no luck so far. will try reinstalling next. I just wanted to know if anyone else has this problem on the ps4? 

Posted 2 years ago

I explained that problem to the support team. Their idea of helping me was asking, if I tried pressing the L2 button all the way.  Really?! 

Well, the problem persists. Yes I pushed the button ALL the way, I checked my controller with other games, no pronlems there, I even reassigned L2 to R2, still nothing, only crosshairs. Scope is not coming up, no matter how much I press that button. I have reinstalled the game 3 times now. I even ordered a brand new controller that should arrive soon.

Does anybody have any idea what the problem could be? Is anybody else having this problem?  Is there a way to get my money refunded in case there is no solution? 

Posted 2 years ago

 i'm having this problem too i've tried two controllers and neither work

Posted 2 years ago

 i have had different problem with the scope, in the fact that the zero doesn't always work properly 


Posted 2 years ago

 Yeah I know the problem it's called rebellion releasing broken games all the time 

Beldeth

Administrator

Posted 2 years ago

 If you are using an Elite controller make sure you have it setup so you can press the L2 in fully.

Over the shoulder scoping will happen when the L2 trigger is not fully pressed.

Posted 2 years ago

 SE4 has a slightly different mechanic than most other shooters, in that a half-pull of the trigger will only show you shoulder-aim crosshairs, while a full pull will get you into ADS/scope.

In many other games, the half-pull will already get you into ADS - as the trigger there functions more like a dialog button (like the on/off buttons on the shoulders) as opposed to the analog triggers.

So even if it seems to "work" in other games, it may be that your controller is only registering a "half-pull" instead of the full pull you do - but for the other games, it makes no difference.

Since you stated that you switched L2 and R2, I assume you have a special/modded controller (or something like the Chronus/Titan Dongle). Some of the special controllers feature a trigger lock that basically limits you to pulling the trigger only halfway - so you can shoot and aim faster without having to fully pull the trigger. While this works for the above-mentioned reasons in most shooters, it does not work in SE4. If you have a special controller, check if it has trigger locks and how you can disable them or try the game with an original new/working controller (as I said, since most shooters make no difference between a full and a half trigger pull, your controller might seem like it works, but that doesn't have to be the case).

If you don't have a special controller (but can still switch L2 and R2), and you have a racing game or demo available, where you know that how far you pull the trigger determines how fast you go, try it out with your controller and see if you can get the full acceleration.

Posted 2 years ago

 Never mind me, that post is like months old... :)

Please sign in to post.