Sniper Elite 4



Frozen Map - No buttons work, no movement

Posted 1 year ago

 Hey - 

Is anyone else having a problem with the in game map? I can pull it up successfully, and it loads, but then it doesn't do anything. None of the buttons work (i.e. zoom, objectives), and it doesn't scroll. The only button that works is the B button, which dismisses the map. It really adds to the difficulty, and not in a very fun way. Happens every time, despite restart of both machine and game.

I'm using the XBox Elite controller, but went back to a normal one without any difference. 

Any ideas? Thanks,


Posted 1 year ago

 I had this same problem.  I had to restart to get the buttons to work.

Posted 1 year ago

 Same here. I had to unplug Xbox and do hard reset. Once I did that the problem cleared.

Posted 1 year ago

 I have never had this problem but I am using a PC I think it is a issue with Xbox.

Posted 11 months ago

 I have this same problem on Xbox One. I know that nobody has responded to this topic in a while, but I hope that someone knows how to fix this map glitch. 

I have tried normal and hard resets, reloading levels, and different gamemodes, but nothing seems to fix it.

Please help! Thanks!

Posted 11 months ago

This has been a problem on the Xbox One for months now. I am not aware of any direct responses from Rebellion on this issue - very disappointing.  I even emailed support directly and got no response. This was the thread I previously posted in:

Anyway, I made some progress with the 1.5.0 patch/Deathstorm 3 update. After installing the update and launching DS part 3, my map was working - this was not the case with I finished DS part 2. I did not complete the DS3 level in one session, and returned the next day. Suddenly my map had stopped working again, just like before.

I tried reloading old saves and the map refused to work (although all other controls in game were working). I then realized that I had swapped controllers because the battery had died on the first controller i started DS3 with. I plugged the original controller into the Xbox, restarted the game, and the map started working again. 

I am only speculating, but it appears there is some connection between the map and the controller used to start the game/level. It does not affect anything else in the game (menus, character control, playing etc all work ok), only the map!

If you look at the original thread, I tried *everything* possible to resolve this problem, so I am not sure if what I tried on DS3 is the solution. I don't recall seeing this bug mentioned in any of the DLC patch notes, so I have no idea if the developers fixed anything.

Posted 11 months ago

 Hi again!

Thanks for the suggestion to change controllers, but it did not fix my problem. I have an old controller that I switched to, just in case I had used it to start the campaign originally, but no luck. The map was still frozen and the buttons did not work.

I also tried starting a new save file with the old controller, but I still had the glitch occur.

Again, thanks for the suggestion! I'll appreciate any other help anyone can offer. Thanks!

Posted 11 months ago

 Hello again!

I finally figured out what my problem was. I had the Guitar Hero Live usb plugged in that allows the guitar to connect. After removing this, the map worked fine!

Thanks again for the help!

Please sign in to post.